Ferramenta de diagnóstico do DirectX

A documentação da ferramenta de diagnóstico do Microsoft® DirectX® contém os seguintes tópicos:

  • Sobre a ferramenta de diagnóstico do DirectX
  • Qual é o problema
  • Testar componentes do DirectX
  • Alterar comportamentos padrão
  • Restaurar drivers
  • Salvar informações
  • Relatar problemas


Sobre a ferramenta de diagnóstico do DirectX

A ferramenta de diagnóstico do DirectX® fornece informações sobre os drivers e componentes de Application Programming Interface (API), interface de programação de aplicativos Microsoft® DirectX em seu sistema e permite que você teste a saída de som e de elementos gráficos, bem como os provedores de serviços DirectPlay®. Ela também permite que você desative alguns recursos de aceleração de hardware.

Você pode usar a ferramenta para colher informações para um técnico durante uma chamada de suporte, ou salvar essas informações e colá-las em uma mensagem de correio eletrônico.

As informações são apresentadas em uma série de páginas. Você pode mover-se entre as páginas através de um dos seguintes métodos:

  • Clique nas guias.
  • Clique no botão Próxima página.
  • Pressione as teclas de direção quando o foco estiver em uma guia.

Observação Alguns dados, como a quantidade de memória em uma placa de vídeo, podem ser aproximados.


Qual é o problema

Se você vem tendo problemas ao executar aplicativos DirectX, a ferramenta de diagnóstico do DirectX pode ajudá-lo a localizar a origem do problema. Aqui estão algumas dicas que você deve pesquisar:

  • Versões incorretas de componentes do DirectX. Na seção Observações da página Arquivos do DirectX, procure por avisos sobre arquivos beta e de depuração. Os arquivos beta são versões anteriores de teste e não devem ser instalados com aplicativos comerciais. As versões de depuração, que são usadas no desenvolvimento de programas e também não devem ser instaladas com o produto final, podem fazer com que os aplicativos se tornem extremamente lentos quando comparados com a versão comercial dos componentes.
  • Drivers não certificados. Na lista de arquivos da página Drivers do DirectX, procure por drivers que estejam marcados como não certificados. Outros problemas podem ser detectados na seção Observações das páginas Vídeo, Som e Entrada. Os drivers não certificados não foram testados pela Microsoft acerca da sua compatibilidade com a versão mais recente do DirectX.
  • Falta de aceleração de hardware. Alguns programas podem ficar muito lentos, a menos que a aceleração de hardware do DirectDraw® ou do Direct3D® esteja ativada. Na página Vídeo, verifique em Recursos do DirectX se o DirectDraw ou o Direct3D estão marcados como "Aceleração não disponível". Nesse caso, deve-se considerar uma atualização de seu hardware.
  • Dispositivo não conectado. Se um joystick ou outro dispositivo de entrada não estiver funcionando, pode ser que ele não esteja corretamente configurado. Certifique-se de que o dispositivo é apresentado na página Entrada da ferramenta de diagnóstico do DirectX. Caso não esteja presente, adicione o dispositivo através do Painel de Controle.


Testar componentes do DirectX

Você pode testar o DirectDraw e o Direct3D em cada monitor conectado ao seu sistema, o DirectSound® em cada dispositivo de saída de som wave, e o DirectMusic® em cada porta de música.

Clique no botão Teste, leia as mensagens exibidas e veja ou ouça os testes. Não interrompa o teste até que seja exibida uma mensagem perguntando se o teste foi bem-sucedido. Se você responder Não, os outros testes não serão executados.

No caso do DirectMusic, há um teste único. Simplesmente, clique em OK quando você achar que a música está sendo reproduzida corretamente.

Você pode também testar a funcionalidade do DirectPlay em qualquer provedor de serviços disponível.

Para testar o DirectPlay:

  1. Na página Rede, clique em Teste do DirectPlay. Na caixa de diálogo Teste do DirectPlay, digite um nome de usuário e escolha o provedor de serviços. Selecione Criar nova sessão e clique em OK. Se você escolheu uma conexão por modem, clique em Resposta na caixa de diálogo Conexão por modem para colocar o modem em modo de auto-resposta.
  2. Agora, execute a ferramenta de diagnóstico do DirectX em outro computador que possa estabelecer a conexão selecionada com o primeiro computador. Clique em Teste do DirectPlay, digite um nome de usuário diferente, escolha o mesmo provedor de serviços, clique no botão Entrar em sessão existente e, em seguida, em OK. Em alguns tipos de conexão, podem ser solicitadas mais informações, como um número de telefone. Em uma conexão TCP/IP em uma rede local, você pode deixar a caixa de texto em branco.
  3. Você deve ver agora uma Lista de sessões no segundo computador contendo o nome da sessão que você criou no primeiro computador. Selecione o nome da sessão e clique em OK.
  4. Ambos os computadores devem agora exibir uma janela de bate-papo. Digite uma mensagem na caixa de entrada em um computador e clique em Enviar. A mensagem deve aparecer na área de rolagem da caixa de diálogo de bate-papo dos dois computadores.


Alterar comportamentos padrão

Na página Som, você pode definir um nível diferente de aceleração de hardware movendo o controle deslizante. Esse nível é mantido após você fechar a ferramenta de diagnóstico do DirectX.

Observação Esse recurso não está disponível no Windows® 95.

Na página Vídeo, para cada dispositivo de vídeo instalado em seu sistema, você pode desativar a aceleração de hardware do DirectDraw ou do Direct3D (se houver aceleração disponível) clicando no botão Desativar. Uma vez desativada a aceleração, ela não estará disponível para nenhum aplicativo, mesmo após você ter fechado a ferramenta de diagnóstico do DirectX. Para reativá-la, clique no botão Ativar.

Observação Desativar a aceleração do DirectDraw também desativa a do Direct3D.

Você também pode alterar a taxa de atualização do monitor definida por aplicativos DirectDraw de tela cheia. Faça isso somente se você tem tido problemas de exibição em certos aplicativos e se houver uma boa razão para acreditar que o aplicativo está definindo uma taxa de atualização inválida.

Para alterar uma taxa de atualização:

  1. Na página Mais Ajuda, clique no botão Alterar.
  2. Na caixa de diálogo Alterar comportamento de atualização do DirectDraw, clique na caixa de edição e digite uma taxa de atualização válida para o seu monitor. Isso fará com que o botão de opção Valor alterado seja selecionado automaticamente.
  3. Clique em OK.

Para cancelar a taxa de atualização alterada e permitir que os aplicativos DirectDraw definam sua própria taxa de atualização:

  1. Na página Mais Ajuda, Clique no botão Alterar.
  2. Na caixa de diálogo Alterar comportamento de atualização do DirectDraw, selecione o botão de opção Padrão.
  3. Clique em OK.


Restaurar drivers

Em algumas configurações, a ferramenta de diagnóstico do DirectX® permite que você restaure os drivers de áudio e vídeo anteriores. Essa pode ser a melhor maneira de solucionar problemas de incompatibilidade de drivers.

Se o botão Restaurar é exibido na página Mais Ajuda, clique nesse botão para executar o programa de instalação do DirectX.

O programa de instalação do DirectX possui dois botões, intitulados Restaurar drivers de áudio e Restaurar drivers de vídeo. Clicar em um desses botões restaura os drivers que foram substituídos quando o DirectX foi instalado em seu sistema. Se um botão estiver desativado, você não possui os drivers anteriores para restaurar. Nesse caso, contate o fabricante do hardware para obter os drivers mais recentes.

O programa de instalação do DirectX também fornece uma caixa de seleção para desativar a aceleração de hardware do Direct3D, o que você já pode ter feito a partir do DxDiag. (Veja Alterar comportamentos padrão.)


Salvar informações

Há duas maneiras de salvar as informações obtidas através da ferramenta de diagnóstico do DirectX:

  • Clique no botão Salvar todas as informações. As informações de todas as páginas serão salvas em um arquivo com nome e local especificados por você.

Ou, se você é um desenvolvedor de software com a versão para desenvolvedores dessa ferramenta:

  • Na página Mais Ajuda, clique em Relatório. A caixa de diálogo Relatório de informações de erros será exibida. Após digitar todos os dados necessários, clique em Enviar. Um arquivo texto chamado Dxdiag.txt é criado no diretório de arquivos temporários (por exemplo, C:\Windows\Temp) e é exibido no Bloco de Notas. Esse arquivo contém as mesmas informações obtidas pelo método anterior, mas também inclui os dados pessoais e outras informações que você digitou.


Relatar problemas

No caso de problemas que você acredita que sejam relacionados a um componente ou driver do DirectX, contate os Serviços de Suporte aos Produtos Microsoft (consulte Ajuda do Microsoft® Windows® em Solução de problemas). Se você é um desenvolvedor de software e possui a versão para desenvolvedores da ferramenta de diagnóstico, pode relatar o problema por correio eletrônico.

Observação Estas instruções aplicam-se somente à versão para desenvolvedores dessa ferramenta. Esta opção não está disponível para todos os usuários.

Para relatar o problema por correio eletrônico:

  1. Clique em Relatório na página Mais Ajuda.
  2. Preencha todas as seções relevantes da caixa de diálogo Relatório de informações de erros e clique em Enviar.
  3. Uma mensagem será exibida, com o caminho completo do arquivo de texto que foi criado e o endereço de correio eletrônico. Anote esse endereço. Clique em OK. O conteúdo de Dxdiag.txt será exibido no Bloco de Notas.
  4. A partir do menu Editar do Bloco de Notas, escolha Selecionar tudo e, em seguida, Copiar, de modo que todo o conteúdo seja colocado na Área de transferência.
  5. Crie uma nova mensagem no seu programa de correio eletrônico e cole o conteúdo da Área de transferência no corpo da mensagem. Envie a mensagem para o endereço que você anotou na etapa 3.


Tópico não encontrado

Nenhum tópico correspondente foi encontrado. Alguns motivos e soluções possíveis estão descritos a seguir:

  • O arquivo (.chm) que contém o tópico de destino não está no local esperado.

    Solução: Execute novamente MSDN Library Setup.

  • O arquivo (.chm) que contém o tópico atual ou de destino está desatualizado e o vínculo não é mais válido.

    Solução: Instale a versão mais recente da MSDN Library.

  • O MSDN Library CD não está na unidade de CD-ROM.

    Solução: Insira o MSDN Library CD na unidade de CD-ROM.

Criado quinta-feira, em 29 de julho de 1999