DirectX 诊断工具

Microsoft® DirectX® 诊断工具文档包括以下主题：

  • 关于 DirectX 诊断工具
  • 注意事项
  • 测试 DirectX 组件
  • 覆盖默认行为
  • 还原驱动程序
  • 保存信息
  • 报告问题


关于 DirectX 诊断工具

DirectX® 诊断工具用于向用户提供系统中 Microsoft® DirectX 应用程序编程接口 (API) 组件和驱动程序的信息，并能够测试声音和图形输出以及 DirectPlay® 服务提供程序。同时，还可以用于禁用某些硬件加速功能。

可以使用此工具收集信息，以便在拨打支持电话时提供给相关技术人员，还可以保存使用该工具收集到的信息并将其粘贴到电子邮件中。

信息分多页显示，使用以下某种方法可以翻页：

  • 单击不同的选项卡。
  • 单击“下一页”按钮。
  • 当输入焦点集中在某个选项卡上时，按向左箭头键或向右箭头键。

注意 某些信息（如显卡内存大小）可能是近似值。


注意事项

如果运行 DirectX 应用程序时出现问题，DirectX 诊断工具可以帮助您找出产生问题的根源。下面是一些需要注意的问题：

  • DirectX 组件版本错误。在“DirectX 文件”页的“说明”部分，查找关于 Beta 文件和调试文件的警告。Beta 文件是早期测试版本，请不要与商用程序一起安装。调试版本一般用于程序开发，不要和最终产品一同安装，否则，将大大降低应用程序的运行速度，使其远远低于在组件零售版下的运行速度。
  • 未经认证的驱动程序。在“DirectX 驱动程序”页的文件列表中，查找标记为未经认证的驱动程序。其它问题会显示在“显示”、“声音”和“输入”页的“说明”部分。未经认证的驱动程序尚未由 Microsoft 与最新版本的 DirectX 进行完全兼容性测试。
  • 缺少硬件加速。如果没有 DirectDraw® 或 Direct3D® 硬件加速，有些程序运行速度很慢，甚至无法运行。在“显示”页的“DirectX 功能”下，查看 DirectDraw 或 Direct3D 是否被标记为“没有加速”。如果被标记为“没有加速”，请考虑硬件升级。
  • 设备未连接。如果游戏杆或其它输入设备没有响应，可能是因为安装不正确。请确认 DirectX 诊断工具的“输入”页中是否已包含该设备。如果不包含，请通过“控制面板”添加该设备。


测试 DirectX 组件

可以在任何与系统相连的监视器上测试 DirectDraw 和 Direct3D，在任何波形输出设备上测试 DirectSound®，在任何音频端口上测试 DirectMusic®。

单击“测试”按钮，阅读显示的任何信息，监视或监听测试过程，并让测试过程一直延续下去，直到出现提示信息，询问测试是否成功。如果回答“否”，将不再进行测试。

对于 DirectMusic，只需进行一次简单的测试。如果您对这段音乐的正确播放感到满意，或者虽然没有正确播放但您也觉得可以，只需单击“确定”。

还可以在任何可用的服务提供程序中测试 DirectPlay 的功能。

测试 DirectPlay：

  1. 在“网络”页，单击“测试 DirectPlay”。在“DirectPlay 测试”对话框中，键入用户名并选择一个服务提供程序。选择“创建新会话”，然后单击“确定”。如果选择了调制解调器连接，请在“调制解调器连接”对话框中单击“应答”，将调制解调器置为自动应答模式。
  2. 现在，请在另一台计算机上运行 DirectX 诊断工具，该计算机应能和第一台计算机建立所选的连接。单击“测试 DirectPlay”，键入另一个用户名，选择相同的服务提供程序，选择“加入现有会话”按钮，然后单击“确定”。对于某些类型的连接，可能要求提供更多的信息，例如电话号码。对于局域网的 TCP/IP 连接，可以让此文本框为空。
  3. 现在，应该在第二台计算机上看到“会话列表”，其中包含在第一台计算机上创建的会话的名称。选择该名称，然后单击“确定”。
  4. 两台计算机现在都应显示聊天对话框。在一台计算机的输入框中键入一条消息，然后单击“发送”。该消息应该显示在两台计算机聊天对话框的滚动区中。


覆盖默认行为

在“声音”页，可以通过移动滑杆设置不同的硬件加速级别。该级别在关闭 DirectX 诊断工具后仍然有效。

注意 该特性在 Windows® 95 上无效。

在系统上安装的每个显示设备的“显示”页中，单击“禁用”按钮，禁用 DirectDraw 或 Direct3D 硬件加速（如果有加速功能的话）。禁用加速之后，加速功能在关闭 DirectX 诊断工具后依然保持禁用，且对任何应用程序都无效。要重新启用硬件加速，请单击“启用”按钮。

注意 禁用 DirectDraw 加速将同时禁用 Direct3D 加速。

也可以覆盖由 DirectDraw 全屏应用程序设置的监视器刷新频率。只有在某些应用程序出现显示问题，并能确认该应用程序设置了无效的刷新频率时，才能这么做。

设置覆盖刷新频率：

  1. 在“其他帮助”页上，单击“覆盖”按钮。
  2. 在“覆盖 DirectDraw 刷新行为”对话框，选择编辑框并为监视器键入有效的刷新频率。此时，“覆盖值”选项按钮将被自动选中。
  3. 单击“确定”。

取消覆盖刷新频率，并允许 DirectDraw 应用程序自行设置刷新频率：

  1. 在“其他帮助”页上，单击“覆盖”按钮。
  2. 在“覆盖 DirectDraw 刷新行为”对话框，选择“默认值”选项按钮。
  3. 单击“确定”。


还原驱动程序

在有些配置下，DirectX® 诊断工具允许用户还原较早的音频和视频驱动程序。这也许是解决驱动程序不兼容问题最好的办法。

如果“其他帮助”页上出现“还原”按钮，则可以单击此按钮运行 DirectX 安装程序。

DirectX 安装程序有两个按钮，即“还原音频驱动程序”和“还原显示驱动程序”。单击其中任一按钮都将还原在系统中安装 DirectX 时被替换的驱动程序。如果某个按钮被禁用，则表明没有可以还原的驱动程序。遇到这种情况时，应与硬件厂商联系，以获取最新的驱动程序。

DirectX 安装程序还提供一个用于禁用 Direct3D 硬件加速的复选框，也许您通过诊断工具对话框已完成此项禁用。（参见覆盖默认行为。）


保存信息

有两种方法可以保存 DirectX 诊断工具收集的信息：

  • 单击“保存所有信息”按钮。所有页的信息都将保存到用户所选位置和名称的文件里。

对于使用此工具开发商版本的软件开发者，则可以：

  • 在“其他帮助”页上，单击“报告”，将出现“错误报告信息”对话框。输入所有必要数据，单击“发送”。将在临时目录（例如，C:\Windows\Temp）中创建一个名为 Dxinfo.txt 的文本文件，同时显示在记事本窗口中。此文件不仅包含采用上述方法收集的信息，还包含所输入的个人信息和其它信息。


报告问题

如果确认出现的问题与 DirectX 组件或驱动程序有关，请与 Microsoft 产品支持服务联系（参见 Microsoft® Windows® 帮助中的疑难解答）。对于使用该诊断工具的开发商版本进行软件开发的人员，可以通过电子邮件报告问题。

注意 此说明仅适用于此工具的开发商版本，并不适用于所有用户。

通过电子邮件报告问题：

  1. 在“其他帮助”页中单击“报告”。
  2. 填写“错误报告信息”对话框的所有相关部分，然后单击“发送”。
  3. 将出现一条消息，给出所创建的文本文件的完整路径以及电子邮件地址。请记下电子邮件地址。单击“确定”。随后，Dxinfo.txt 文件将在“记事本”窗口中打开。
  4. 从“记事本”的“编辑”菜单，选择“全选”，然后选择“复制”，将全部内容复制到剪贴板中。
  5. 在邮件程序里创建新邮件，并将剪贴板的内容粘贴到邮件中。按第 3 步中记下的地址发送邮件。


未找到主题

没有找到匹配的主题。下面列出了可能的原因和解决办法：

  • 包含目标主题的文件 (.chm) 没有位于预期的位置。

    解决办法：重新运行 MSDN 库安装程序。

  • 包含当前主题或目标主题的文件 (.chm) 已过期，链接不再有效。

    解决办法：安装最新版本的 MSDN 库。

  • MSDN 库 CD 没有放到 CD-ROM 驱动器中。

    解决办法：将 MSDN 库 CD 插入 CD-ROM 驱动器。

建立于 1999 年 7 月 29 日，星期四