DirectX 診斷工具

Microsoft® DirectX® 診斷工具文件包含下列標題：

  • 關於 DirectX 診斷工具
  • 注意事項
  • 測試 DirectX 元件
  • 強制覆寫預設的設定
  • 還原驅動程式
  • 儲存資訊
  • 報告問題


關於 DirectX 診斷工具

DirectX® 診斷工具提供系統上 Microsoft® DirectX 應用程式設計介面 (API) 元件與驅動程式的相關資訊，可讓您測試音效、圖形輸出以及 DirectPlay® 服務提供者，也可以讓您停用部份的硬體加速功能。

您可以使用本工具收集資訊，以便在支援呼叫時提供給技術人員, 或者儲存本工具所收集的資訊，然後貼到電子郵件中。

資訊會顯示於連續畫面上，您可以使用下列其中一種方式來移動畫面：

  • 按一下標籤。
  • 按一下 [下一頁] 按鈕。
  • 當輸出焦點位在標籤上時，請按向左或向右鍵。

注意 顯示卡記憶體總數等部份資訊可能是估計值。


注意事項

在執行 DirectX 應用程式時如果遇到問題，DirectX 診斷工具可以幫助您找出問題的原因所在。以下是您應該注意的事項：

  • DirectX 元件的版本不正確。在 [DirectX 檔案] 畫面的 [注意事項] 小節中查詢關於測試與偵錯檔案的警告。測試檔案是早期的測試版本，不應該與商業應用程式安裝在一起。偵錯版本則用於程式開發，同樣不應該與正式版產品安裝在一起，因為這樣會造成應用程式執行的速度比在元件的零售版本之下執行得更慢。
  • 驅動程式未認證。在 [DirectX 驅動程式] 畫面的檔案清單中查詢標示為未認證的驅動程式。其他問題可能會顯示於 [顯示]、[音效] 以及 [輸入] 畫面的 [注意事項] 小節中。未認證的驅動程式並未經過 Microsoft 測試與最新版 DirectX 的完整相容性。
  • 硬體加速不足。除非使用 DirectDraw® 或 Direct3D® 硬體加速，否則有些程式執行的速度會相當地慢或根本無法執行。請查詢 [顯示] 畫面之下的 [DirectX 功能]，了解 DirectDraw 或 Direct3D 是否標示為 [沒有加速功能可用]。若是如此，請考慮升級您的硬體。
  • 裝置未連接。如果搖桿或其他輸入裝置回應失敗，則可能是安裝不適當的關係。請確認 DirectX 診斷工具的 [輸入] 畫面上有該裝置的說明。如果沒有，請透過控制台新增裝置。


測試 DirectX 元件

您可以在每個與系統連接的監視器上測試 DirectDraw 與 Direct3D、在每個聲音輸出裝置上測試 DirectSound®，以及在每個音樂連接埠上測試 DirectMusic®。

按一下 [測試] 按鈕，詳讀任何顯示的訊息，然後監看或聆聽測試。執行每項測試，直到您看到訊息問您測試是否成功為止。如果您回應 [否]，系統便不會再執行任何測試。

在 DirectMusic 情況中會有個單一測試。當您對正確或不正確播放的音樂感到滿意時，請按一下 [確定]。

您也可以在任何可用的服務提供者上測試 DirectPlay 的功能。

測試 DirectPlay：

  1. 在 [網路] 畫面上按一下 [測試 DirectPlay]。在 [DirectPlay 測試] 對話方塊中輸入使用者名稱並選擇服務提供者，選擇 [建立新工作階段]，再按 [確定]。如果您選擇了數據機連線，請按一下 [數據機連線] 對話方塊中的 [回答]，將數據機置於自動回答模式中。
  2. 現在請在可以連線到第一部電腦的其他電腦上執行 DirectX 診斷工具。按一下 [測試 DirectPlay]，輸入不同的使用者名稱，選擇相同的服務提供者，選擇 [加入現存的工作階段] 按鈕，再按 [確定]。某些類型的連線可能會要求您提供更詳細的資訊，例如電話號碼。至於區域網路的 TCP/IP 連線，您可以讓文字方塊保留空白。
  3. 現在您應該會在第二部電腦上看到 [工作階段清單]，其中包含您在第一部電腦上建立的工作階段名稱。請選擇工作階段的名稱，再按 [確定]。
  4. 現在兩部電腦上都會顯示談天對話方塊。請在其中一部電腦的輸入方塊中輸入訊息，再按 [傳送]。此訊息應該會同時顯示在兩部電腦上談天對話方塊的捲動區域中。


強制覆寫預設的設定

在 [音效] 畫面中可以藉由移動滑軸，設定不同的硬體加速層級。當停用 DirectX 診斷工具之後，仍會保留此層級且可繼續使用。

注意 Windows® 95 不提供此功能。

在系統安裝的每一個顯示裝置的 [顯示] 畫面中，只要按一下 [停用] 按鈕，即可關閉 DirectDraw 或 Direct3D 的硬體加速功能 (不過必須是已經有類似的加速功能)。一旦停用加速功能後，就算您關閉 DirectX 診斷工具，它仍然會保留在停用的狀態，而且任何應用程式都無法使用加速功能。要重新啟用它，請按一下 [啟動] 按鈕。

注意 停用 DirectDraw 加速功能也會停用 Direct3D 的加速功能。

您也可以強制覆寫 DirectDraw 全螢幕應用程式設定的監視器更新速率。只有當您在特定應用程式發生顯示問題，而且也深信應用程式設定的更新速率無效時，才可以這樣做。

要設定強制覆寫的更新速率：

  1. 在 [其他說明] 畫面按一下 [強制覆寫] 按鈕。
  2. 在 [強制覆寫 DirectDraw 的更新設定] 對話方塊中選取編輯方塊，並輸入有效的監視器更新速率；在您執行此項時，會自動選取 [強制覆寫數值] 選項按鈕。
  3. 按一下 [確定]。

要取消強制覆寫更新速率，然後允許 DirectDraw 應用程式設定自己的更新速率：

  1. 在 [其他說明] 畫面按一下 [強制覆寫] 按鈕。
  2. 在 [強制覆寫 DirectDraw 的更新設定 ] 對話方塊選擇 [預設值] 選項按鈕。
  3. 按一下 [確定]。


還原驅動程式

在某些組態中，DirectX® 診斷工具可以讓您還原舊的音效與顯示驅動程式。這可能是解決驅動程式不相容問題的最好方法。

如果 [還原] 按鈕顯示於 [其他說明] 畫面上，請按一下這個按鈕執行 DirectX 安裝程式。

DirectX 安裝程式有兩個按鈕分別標示為 [還原音效驅動程式] 和 [還原顯示驅動程式]。按一下其中一個就會還原當 DirectX 安裝到系統時受到取代的驅動程式。如果無法使用此按鈕，您就不能還原舊的驅動程式。在這種情況下，請洽詢硬體製造商，取得最新的驅動程式。

DirectX 安裝程式也提供核取方塊來停用 Direct3D 硬體加速，其中有些項目您已經從 DxDiag 執行了。(請參閱強制覆寫預設的設定)。


儲存資訊

儲存 DirectX 診斷工具收集資訊的方法有兩種：

  • 按一下 [儲存所有資訊] 按鈕。所有畫面的資訊會儲存成某一個名稱的檔案，然後放到您選擇的位置。

或者，若您是軟體開發員，使用此工具的 developer 版本：

  • 在 [其他說明] 畫面按一下 [報告]。會顯示 [問題報告資訊] 對話方塊。當您輸入所有必要的資料後，請按一下 [傳送]。這樣會在您的暫存目錄 (例如，C:\Windows\Temp) 建立一個名稱為 Dxdiag.txt 的文字檔，然後顯示在記事本視窗。此檔案包含的資訊與先前方法收集的資訊相同，但是也包括您已經輸入的個人和其他資訊。


報告問題

若您發生問題而且您相信與 DirectX 元件或驅動程式有關，您可以洽詢 Microsoft 產品支援服務 (請參閱 Microsoft® Windows® [說明] 中的 [疑難排解])。若您是軟體開發人員，而且使用診斷工具的 developer 版本，您可以使用電子郵件報告問題。

注意 這些指示僅適用於此工具的 developer 版本。此選項不提供給所有使用者。

要使用電子郵件報告問題：

  1. 按一下 [其他說明] 畫面上的 [報告]。
  2. 填寫 [問題報告資訊] 對話方塊所有相關的區段，然後按一下 [傳送]。
  3. 會出現訊息，顯示已建立文字檔的完整路徑和電子郵件地址。記下電子郵件地址。按一下 [確定]。會顯示記事本視窗，裏面是 Dxdiag.txt 的內容。
  4. 從記事本的 [編輯] 功能表選擇 [選擇全部]，然後按一下 [複製]，將檔案內容全都放到剪貼簿上。
  5. 在電子郵件程式撰寫新郵件，然後將剪貼簿的內容貼到郵件內文。將郵件傳送到步驟 3 找到的地址中。


找不到主題

找不到相符的主題。以下列出一些可能的原因與解決辦法：

  • 包含目標主題的檔案 (.chm) 不在預期的位置中。

    解決辦法：重新執行 MSDN 程式庫安裝程式。

  • 包含目前主題或目標主題的檔案 (.chm) 已經過時，連結已不再有效。

    解決辦法：安裝最新版本的 MSDN 程式庫。

  • MSDN 程式庫 CD 不在光碟機中。

    解決辦法：將 MSDN 程式庫 CD 插入光碟機中。

建立於 1999 年 7 月 29 日，星期四