DirectX-diagnoseprogramma

De documentatie bij het Microsoft® DirectX®-diagnoseprogramma bevat de volgende onderwerpen:

  • Info over het DirectX-diagnoseprogramma
  • Waarop u moet letten
  • DirectX-onderdelen testen
  • De standaardwerking wijzigen
  • Stuurprogramma's terugzetten
  • Informatie opslaan
  • Problemen rapporteren


Info over het DirectX-diagnoseprogramma

Het DirectX®-diagnoseprogramma geeft informatie over de API-componenten (Application Programming Interface) en stuurprogramma's van Microsoft® DirectX op uw systeem. U kunt met dit programma ook de uitvoer van geluid en afbeeldingen testen, evenals DirectPlay®-serviceproviders. Bovendien kunt u hiermee bepaalde versnellingsfuncties voor hardware uitschakelen.

U kunt het programma gebruiken om gegevens te verzamelen voor een technicus die telefonische ondersteuning aan een klant biedt. U kunt de gegevens die zijn verzameld met het hulpprogramma ook opslaan en in een e-mailbericht plakken.

De gegevens worden op een reeks pagina's weergegeven. U kunt op verschillende manieren naar een andere pagina gaan:

  • Klikken op de tabs.
  • Klikken op de knop Volgende pagina.
  • Drukken op de pijltoets-links of -rechts als een tab is geselecteerd.

Opmerking Sommige gegevens, zoals de geheugenruimte op een weergavekaart, kunnen een schatting zijn.


Waarop u moet letten

Als u bij de uitvoering van DirectX-toepassingen problemen ondervindt, kan het DirectX-diagnoseprogramma u helpen om de oorzaak van het probleem op te sporen. Hier volgen enkele zaken waarop u moet letten:

  • Onjuiste versies van DirectX-onderdelen. Het gedeelte Opmerkingen van de pagina DirectX-bestanden kan waarschuwingen bevatten betreffende bèta- en debugbestanden. Bètabestanden zijn vroege testversies en mogen niet worden geïnstalleerd in commerciële toepassingen. Debugversies, die worden gebruikt bij de programmaontwikkeling en die evenmin mogen worden geïnstalleerd in het uiteindelijke product, kunnen toepassingen aanzienlijk vertragen (veel meer dan in de uiteindelijke versie van de onderdelen).
  • Ongecertificeerde stuurprogramma's. Ga na of de bestandenlijst op de pagina DirectX-stuurprogramma's stuurprogramma's bevat die zijn gemarkeerd als niet-gecertificeerd. Andere problemen worden wellicht vermeld in het gedeelte Opmerkingen van de pagina's Beeldscherm, Geluid en Invoer. Niet-gecertificeerde stuurprogramma's zijn niet door Microsoft getest op volledige compatibiliteit met de laatste versie van DirectX.
  • Onvoldoende hardwareversnelling. Sommige programma's werken heel traag of helemaal niet, tenzij de hardwareversnelling van DirectDraw® of Direct3D® beschikbaar is. Kijk op de pagina Beeldscherm onder DirectX-functies of bij DirectDraw of Direct3D is aangegeven dat er geen versnelling beschikbaar is. Indien dat het geval is, kunt u overwegen om uw hardware te upgraden.
  • Niet-verbonden apparaat. Als een joystick of ander invoerapparaat niet reageert, is dit wellicht niet goed ingesteld. Controleer of het apparaat vermeld staat op de pagina Invoer van het DirectX-diagnoseprogramma. Indien dat niet het geval is, voegt u het apparaat toe via het Configuratiescherm.


DirectX-onderdelen testen

DirectDraw en Direct3D kunt u testen op elk beeldscherm dat op uw systeem is aangesloten, DirectSound® op elk uitvoerapparaat voor geluidsgolven en DirectMusic® op elke muziekpoort.

Klik op de knop Testen, lees de berichten die worden weergegeven en kijk of luister naar de tests. Voer elke test uit totdat u een bericht krijgt met de vraag of de test geslaagd is. Als u Nee antwoordt, worden er geen tests meer uitgevoerd.

In het geval van DirectMusic is er slechts één test. Klik op OK nadat u hebt vastgesteld of de muziek wel of niet goed wordt afgespeeld.

U kunt de DirectPlay-functionaliteit ook testen bij een willekeurige beschikbare serviceprovider.

DirectPlay testen:

  1. Klik op de pagina Netwerk op DirectPlay testen. Typ in het dialoogvenster DirectPlay testen een gebruikersnaam en kies een serviceprovider. Selecteer Nieuwe sessie maken en klik op OK. Als u een modemverbinding hebt gekozen, klikt u op Opnemen in het dialoogvenster Modemverbinding om automatische beantwoording in te schakelen voor de modem.
  2. Voer vervolgens DirectX-diagnoseprogramma uit op een andere computer die de geselecteerde verbinding met de eerste computer kan maken. Klik op DirectPlay testen, typ een andere gebruikersnaam, kies dezelfde serviceprovider, klik op de knop Deelnemen aan bestaande sessie en klik op OK. Bij sommige verbindingstypen worden wellicht aanvullende gegevens gevraagd, zoals een telefoonnummer. Bij een TCP/IP-verbinding op een lokaal netwerk kunt u het tekstvak leeg laten.
  3. U moet nu op de tweede computer een Sessielijst zien met de naam van de sessie die u op de eerste computer hebt gemaakt. Selecteer de naam van de sessie en klik op OK.
  4. Op beide computers moet nu een chat-dialoogvenster worden weergegeven. Typ een bericht in het invoervak op een van de computers en klik op Verzenden. Het bericht moet vervolgens worden weergegeven in het bladergebied van het chat-dialoogvenster van beide computers.


De standaardwerking wijzigen

Op de pagina Geluid kunt u een ander niveau voor de hardwareversnelling instellen door de schuif te verplaatsen. Dit niveau blijft van kracht nadat u het DirectX-diagnoseprogramma hebt afgesloten.

Opmerking deze functie is niet beschikbaar in Windows® 95.

Op de pagina Beeldscherm van elk weergaveapparaat dat in uw systeem is geïnstalleerd, kunt u de hardwareversnelling uitschakelen voor DirectDraw of Direct3D (voor zover versnelling beschikbaar is) door te klikken op de knop Uitschakelen. De versnelling blijft dan uitgeschakeld, ook als u het DirectX-diagnoseprogramma afsluit, en is niet beschikbaar voor andere toepassingen. Als u de versnelling weer wilt inschakelen, klikt u op de knop Inschakelen.

Opmerking Door de DirectDraw-versnelling uit te schakelen, schakelt u ook de versnelling voor Direct3D uit.

U kunt ook de vernieuwingsfrequentie van het beeldscherm wijzigen, die is ingesteld door de DirectDraw-toepassingen die het volledige scherm gebruiken. U moet dit alleen doen als u weergaveproblemen hebt in bepaalde toepassingen en u vermoedt dat de toepassing een ongeldige vernieuwingsfrequentie instelt.

De vernieuwingsfrequentie wijzigen:

  1. Klik op de pagina Meer Help op de knop Wijzigen.
  2. Selecteer het invoervak in het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen en typ een geldige frequentie voor uw beeldscherm. Het keuzerondje Waarde wijzigen wordt hierbij automatisch geselecteerd.
  3. Klik op OK.

De gewijzigde vernieuwingsfrequentie annuleren en DirectDraw-toepassingen zelf de frequentie laten instellen:

  1. Klik op de pagina Meer Help op de knop Wijzigen.
  2. Selecteer in het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen het keuzerondje Standaard.
  3. Klik op OK.


Stuurprogramma's terugzetten

Bij sommige configuraties kunt u met het DirectX®-diagnoseprogramma oudere audio- en videostuurprogamma's terugzetten. Dit is vaak de beste methode om problemen met niet-compatibele stuurprogramma's op te lossen.

Klik als de knop Terugzetten wordt weergegeven op de pagina Meer Help op deze knop om het programma DirectX Setup uit te voeren.

DirectX Setup bevat twee knoppen, Geluidsstuurprogamma's terugzetten en Beeldschermstuurprogramma's terugzetten. Als u op een van deze twee knoppen klikt, worden de stuurprogramma's die zijn vervangen tijdens de installatie van DirectX teruggezet op uw systeem. Als een knop niet beschikbaar is, zijn er geen oudere stuurprogramma's die u kunt terugzetten. Neem in dat geval contact op met uw hardwareleverancier om de nieuwste stuurprogramma's te verkrijgen.

DirectX Setup bevat ook een selectievakje waarmee u Direct3D-hardwareversnelling kunt uitschakelen. Dit kunt u ook doen vanuit DxDiag. (Zie De standaardwerking wijzigen.)


Informatie opslaan

U kunt de informatie die met het DirectX-diagnoseprogramma is verzameld, op twee manieren opslaan:

  • Klik op de knop Alle gegevens opslaan. De gegevens van alle pagina's wordt opgeslagen in een bestand, met de naam en de locatie die u kiest.

Als u een softwareontwikkelaar bent en de ontwikkelversie van dit programma gebruikt:

  • Klik op de knop Rapportage op de pagina Meer Help. Het dialoogvenster Gegevens over bugrapportage wordt weergegeven. Als u alle benodigde gegevens hebt ingevoerd, klikt u op Verzenden. Er wordt een tekstbestand met de naam Dxdiag.txt gemaakt in uw tijdelijke map (bijvoorbeeld C:\Windows\Temp). Dit bestand wordt weergegeven in een Kladblok-venster en bevat dezelfde gegevens als bij de eerste methode, plus de persoonlijke en overige gegevens die u hebt ingevoerd.


Problemen rapporteren

Als er een probleem optreedt en u vermoedt dat dit wordt veroorzaakt door een DirectX-onderdeel of -stuurprogramma, neemt u contact op met de productondersteuning van Microsoft (zie Microsoft® Windows® Help onder Probleemoplossing). Als u softwareontwikkelaar bent en met de ontwikkelversie van het diagnoseprogramma werkt, kunt u het probleem per e-mail rapporteren.

Opmerking Deze instructies zijn alleen van toepassing op de ontwikkelversie van dit programma. Deze optie is niet voor alle gebruikers beschikbaar.

Het probleem per e-mail rapporteren:

  1. Klik op de knop Rapportage op de pagina Meer Help.
  2. Vul alle relevante delen in van het dialoogvenster Gegevens over bugrapportage en klik vervolgens op Verzenden.
  3. Er wordt een bericht weergegeven met het volledige pad van het gemaakte tekstbestand en met het e-mailadres. Noteer het e-mailadres en klik op OK. Er wordt een Kladblok-venster geopend met de inhoud van Dxdiag.txt.
  4. Kies in het menu Bewerken van Kladblok de opdracht Alles selecteren en kies vervolgens Kopiëren om de volledige inhoud van het bestand op het Klembord te plaatsen.
  5. Maak een nieuw bericht in uw e-mailprogramma en plak de inhoud van het Klembord in de berichttekst. Verstuur het bericht naar het adres dat u in stap 3 hebt genoteerd.


Onderwerp niet gevonden

Er is geen overeenkomstig onderwerp gevonden. Enkele mogelijke oorzaken en oplossingen zijn:

  • Het bestand (.chm) dat het doelonderwerp bevat bevindt zich niet op de verwachte plaats.

    Oplossing: installeer de MSDN Library opnieuw.

  • Het bestand (.chm) dat het huidige onderwerp of het doelonderwerp bevat is verouderd, en de koppeling is niet meer geldig.

    Oplossing: installeer de nieuwste versie van de MSDN Library.

  • De MSDN Library-cd bevindt zich niet in het cd-romstation.

    Oplossing: plaats de MSDN Library-cd in het cd-romstation.

Gemaakt op donderdag 29 juli 1999