Средство диагностики DirectX

Справка по средству диагностики Microsoft® DirectX® включает следующие разделы.

  • О средстве диагностики DirectX
  • Поиск информации
  • Тестирование компонентов DirectX
  • Переопределение характеристик по умолчанию
  • Восстановление драйверов
  • Сохранение информации
  • Отчет об ошибках


О средстве диагностики DirectX

Средство диагностики DirectX® позволяет не только получать сведения о компонентах интерфейса программирования приложений Microsoft® DirectX и драйверах компьютера, но и выполнять тестирование звуковых и графических данных на выходе, а также поставщиков служб DirectPlay®. Кроме того, пользователь имеет возможность отключить некоторые средства аппаратного ускорения.

Данное средство позволяет выполнить сбор сведений, которые потребуются при обращении в службу технической поддержки, а также включить собранную информацию в сообщение электронной почты.

Информация представлена на нескольких страницах. Для переходов со страницы на страницу можно использовать любой из следующих способов:

  • Щелкните нужную вкладку.
  • Нажмите кнопку Следующая.
  • Нажмите клавишу СТРЕЛКА ВЛЕВО или СТРЕЛКА ВПРАВО, когда фокус ввода находится на вкладке.

Примечание. Некоторые данные, такие как объем памяти на видеоплате, могут быть указаны приблизительно.


Поиск информации

Средство диагностики DirectX помогает обнаружить источники неполадок при выполнении приложений DirectX. Ниже перечислены некоторые возможные источники неполадок.

  • Неправильные версии компонентов DirectX. В разделе Примечания страницы Файлы DirectX просмотрите предупреждения о бета-версиях и отладочных файлах. Бета-версии являются ранними пробными версиями, которые не должны устанавливаться коммерческими приложениями. Отладочные версии, которые используются при разработке программ, также не должны устанавливаться конечными продуктами, поскольку они выполняются существенно медленнее коммерческих версий соответствующих компонентов.
  • Несертифицированные драйверы. В списке файлов на странице Драйверы DirectX просмотрите драйверы, которые помечены как несертифицированные. Другие причины затруднений могут быть перечислены в разделах Примечания на страницах Дисплей, Звук и Ввод. Несертифицированные драйверы не были проверены Microsoft на полную совместимость с последней версией DirectX.
  • Отсутствие аппаратного ускорения. Некоторые программы выполняются очень медленно или вообще не выполняются в отсутствие аппаратного ускорения DirectDraw® или Direct3D®. На странице Дисплей проверьте в группе Возможности DirectX, имеется ли для DirectDraw или Direct3D метка «Ускорение отсутствует». Если да, рассмотрите возможность обновления оборудования.
  • Устройство не подключено. Если джойстик или другое устройство ввода не отвечает, то возможно, оно было неверно установлено. Проверьте, что устройство включено в список на странице Ввод средства диагностики DirectX. Если нет, добавьте устройство с помощью панели управления.


Тестирование компонентов DirectX

DirectDraw и Direct3D можно тестировать на любом мониторе, присоединенном к компьютеру, DirectSound® на любом звуковом выводном устройстве, а DirectMusic® на любом музыкальном порте.

Нажмите кнопку Проверка, прочитайте появляющиеся сообщения и просмотрите или прослушайте тесты. Позвольте каждому тесту выполняться, пока не появится сообщение с вопросом, был ли тест успешным. Если пользователь ответит Нет, другие тесты не будут выполнены.

Для DirectMusic имеется всего один тест. Просто нажмите кнопку ОК, когда поймете, правильно ли воспроизводится музыка.

Кроме того, существует возможность тестирования функциональных возможностей DirectPlay для любого имеющегося поставщика служб.

Чтобы проверить DirectPlay:

  1. На странице Сеть нажмите кнопку Проверить DirectPlay. В диалоговом окне Проверка DirectPlay введите имя пользователя и выберите поставщика службы. Выберите параметр Создать новый сеанс и нажмите кнопку ОК. Если было выбрано подключение через модем, нажмите кнопку Ответить в диалоговом окне Подключение через модем, чтобы перевести модем в режим автоответчика.
  2. Теперь запустите средство диагностики DirectX на другом компьютере, способном установить выбранное соединение с первым компьютером. Нажмите кнопку Проверить DirectPlay, введите другое имя пользователя, выберите того же поставщика службы, выберите параметр Подсоединиться к существующему сеансу и нажмите кнопку ОК. Для некоторых типов подключений может потребоваться указать дополнительные сведения, например номер телефона. Для подключений TCP/IP в локальной сети это поле можно оставить пустым.
  3. На втором компьютере должно появиться диалоговое окно Список сеансов, содержащее имя сеанса, созданного на первом компьютере. Выберите нужный сеанс и нажмите кнопку OK.
  4. На обоих компьютерах должно появиться окно разговора. Введите произвольное сообщение в область ввода на одном компьютере и нажмите кнопку Отправить. Это же сообщение должно появиться в области прокрутки диалогового окна разговора на обоих компьютерах.


Переопределение характеристик по умолчанию

На странице Звук можно изменить уровень аппаратного ускорения путем перемещения соответствующего бегунка. Этот уровень будет продолжать действовать после закрытия средства диагностики DirectX.

Примечание. Эта возможность отсутствует в Windows® 95.

На странице Дисплей для каждого дисплея, установленного на компьютере, можно с помощью кнопки Отключить отключить аппаратное ускорение для DirectDraw или Direct3D (если средства аппаратного ускорения имеются). Даже после закрытия средства диагностики DirectX ускорение остается отключенным и недоступным для любых приложений. Чтобы снова включить ускорение, нажмите кнопку Включить.

Примечание. Отключение ускорения DirectDraw приводит к отключению ускорения для Direct3D.

Пользователь имеет также возможность переопределить частоту обновления монитора, установленную полноэкранными приложениями DirectDraw. Это следует делать только в том случае, если у некоторых приложений возникают неполадки с экраном, и имеются причины подозревать, что приложение устанавливает недопустимую частоту обновления.

Чтобы переопределить частоту обновления:

  1. На странице Ничего не помогло? нажмите кнопку Перекрыть.
  2. В диалоговом окне Перекрытие частоты обновления экрана DirectDraw выберите поле и введите частоту обновления, допустимую для вашего монитора. При этом автоматически выбирается параметр Другое значение.
  3. Нажмите кнопку OK.

Чтобы отменить переопределение частоты обновления и позволить приложениям DirectDraw задавать собственную частоту обновления:

  1. На странице Ничего не помогло? нажмите кнопку Перекрыть.
  2. В диалоговом окне Перекрытие частоты обновления экрана DirectDraw выберите параметр По умолчанию.
  3. Нажмите кнопку OK.


Восстановление драйверов

В некоторых конфигурациях средство диагностики DirectX® позволяет восстанавливать старые драйверы видео и аудиозаписей. Возможно, это наиболее эффективный способ разрешения проблем, связанных с несовместимостью драйверов.

Если на странице Ничего не помогло? имеется кнопка Восстановить, нажмите ее, чтобы запустить программу установки DirectX.

Программа установки DirectX имеет две кнопки: Восстановить драйверы звука и Восстановить драйверы экрана. Нажатие любой из них приведет к восстановлению драйверов, замененных при установке DirectX на компьютер. Если кнопка недоступна, отсутствуют старые драйверы, которые можно восстановить. В этом случае обратитесь за новыми драйверами к разработчику оборудования.

В программе установки DirectX имеется также флажок отключения аппаратного ускорения Direct3D, что вы, возможно, уже выполнили с помощью средства диагностики DirectX. (См. раздел Переопределение характеристик по умолчанию.)


Сохранение информации

Существуют два способа сохранения информации, собранной средством диагностики DirectX.

  • Нажмите кнопку Сохранить все сведения. Данные со всех страниц будут сохранены в файле, имя и положение которого указывается пользователем.

При работе с версией данного диагностического средства для разработчика.

  • На странице Ничего не помогло? нажмите кнопку Отчет. Откроется диалоговое окно Отчет об ошибках. Введите все необходимые данные и нажмите кнопку Отправить. Текстовый файл с именем Dxdiag.txt будет создан в каталоге временных файлов (например, C:\Windows\Temp) и открыт в окне программы Блокнот. Этот файл будет содержать все данные, собранные предыдущим способом, а также введенные вами личные и другие данные.


Отчет об ошибках

Если возникают неполадки, которые, как вы полагаете, связаны с компонентом DirectX или драйвером, обращайтесь в службу поддержки продуктов Microsoft (см. раздел «Устранение неполадок» в справке Microsoft® Windows®). Разработчики программного обеспечения, использующие выпуск данного средства для разработчиков, могут сообщать о неполадках по электронной почте.

Примечание. Следующие инструкции относятся только к выпуску для разработчиков. Эта возможность недоступна для остальных пользователей.

Чтобы отправить отчет об ошибках по электронной почте:

  1. На странице Ничего не помогло? нажмите кнопку Отчет.
  2. Заполните все существенные разделы в диалоговом окне Отчет об ошибках и нажмите кнопку Отправить.
  3. На экране появится сообщение, содержащее полный путь к созданному текстовому файлу и адрес электронной почты. Запишите этот адрес электронной почты. Нажмите кнопку OK. Затем откроется окно программы Блокнот, содержащее файл Dxdiag.txt.
  4. В меню Правка программы Блокнот выберите команды Выделить все и Копировать, чтобы поместить все содержимое файла в буфер обмена.
  5. Создайте новое сообщение в имеющейся программе электронной почты и вставьте содержимое буфера обмена в область текста сообщения. Отправьте сообщение по адресу, записанному на шаге 3.


Раздел не найден

Подходящий раздел не найден. Возможные причины и способы устранения неисправности:

  • Содержащий нужный раздел файл (.chm) находится в другом месте.

    Устранение: перезапустите установку библиотеки MSDN.

  • Устарел файл (.chm), содержащий текущий или указанный раздел, и эта ссылка больше недоступна.

    Устранение: установите последнюю версию библиотеки MSDN.

  • Компакт-диск библиотеки MSDN не вставлен в дисковод.

    Устранение: вставьте компакт-диск библиотеки MSDN в дисковод.